rbenvでRuby2.1.1をインストールするときにエラーが出る問題の解消

rbenvでRuby2.1.1をインストールするときにエラーが出る問題の解消rbenvでruby2.1.1をインストールしようとするとエラーが出て失敗してしまう。これを解消するための方法を見つけました(調べれば出てきますが)。パッチを当ててインストールするらしいです。2.0.0-p451も同様の問題があって解消法は下記のリンクに書いてあります。

ちなみに、この問題はruby2.2.0では解消しているようです。

2.1.1

curl https://gist.githubusercontent.com/andschwa/11334511/raw/563d5c2efb869cafb0c65404d12243822bba2817/ruby-2.1.1-readline.patch | rbenv install --patch 2.1.1

参考

Pocket
LINEで送る

You may also like...